Requirements

Tyk uses LuaJIT. The main requirement is the LuaJIT shared library, you may find this as libluajit-x in most distros.

For Ubuntu 14.04 you may use:

$ apt-get install libluajit-5.1-2
$ apt-get install luarocks

The LuaJIT required modules are as follows:

  • lua-cjson: in case you have luarocks, run:
    $ luarocks install lua-cjson
Was this article helpful to you? Yes No